qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] vfio/pci: rename vfio_put_device to vfio_pci_put_device


From: Cédric Le Goater
Subject: Re: [PATCH] vfio/pci: rename vfio_put_device to vfio_pci_put_device
Date: Fri, 22 Sep 2023 16:34:52 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.13.0

On 9/22/23 04:52, Zhenzhong Duan wrote:
vfio_put_device() is a VFIO PCI specific function, rename it with
'vfio_pci' prefix to avoid confusing.

No functional change.

There is more to be done but it can wait after the big code reshuffle.

Suggested-by: Cédric Le Goater <clg@redhat.com>
Signed-off-by: Zhenzhong Duan <zhenzhong.duan@intel.com>

Applied to vfio-next.

Thanks,

C.

---
  hw/vfio/pci.c | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/hw/vfio/pci.c b/hw/vfio/pci.c
index 3b2ca3c24ca2..b2d5010b9f0e 100644
--- a/hw/vfio/pci.c
+++ b/hw/vfio/pci.c
@@ -2826,7 +2826,7 @@ static void vfio_populate_device(VFIOPCIDevice *vdev, 
Error **errp)
      }
  }
-static void vfio_put_device(VFIOPCIDevice *vdev)
+static void vfio_pci_put_device(VFIOPCIDevice *vdev)
  {
      g_free(vdev->vbasedev.name);
      g_free(vdev->msix);
@@ -3317,7 +3317,7 @@ static void vfio_instance_finalize(Object *obj)
       *
       * g_free(vdev->igd_opregion);
       */
-    vfio_put_device(vdev);
+    vfio_pci_put_device(vdev);
      vfio_put_group(group);
  }




reply via email to

[Prev in Thread] Current Thread [Next in Thread]