[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Compiling a2ps on Cygwin under Win 98 and/or Win 2k

From: Dominic.Large
Subject: Compiling a2ps on Cygwin under Win 98 and/or Win 2k
Date: Wed, 8 Jan 2003 14:14:48 -0000

I've been trying to get a2ps to build on Cygwin for Win 2k and Win 98, but I've not been able to get it to work successfully.
Before going any further, I'll just mention that I'm one of the lazy types that tries to get pre-compiled stuff before trying to install from source; so I may be doing something mind-numbingly stupid, or not doing something blindingly obvious.  I have tried Google searches and mailing list searches over the last few days for hints, but I can't find anything that helps.
On to the actual problem: configure seems to work OK, but when I run make the build fails with the following error:
Making all in intl
make[2]: Entering directory `/cygdrive/c/WINDOWS/Desktop/Downloads/Productivity/a2pstmp/a2ps-4.13/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/cygdrive/c/WINDOWS/Desktop/Downloads/Productivity/a2pstmp/a2ps-4.13/intl'
Making all in lib
make[2]: Entering directory `/cygdrive/c/WINDOWS/Desktop/Downloads/Productivity/a2pstmp/a2ps-4.13/lib'
source='path-concat.c' object='path-concat.lo' libtool=yes \
depfile='.deps/path-concat.Plo' tmpdepfile='.deps/path-concat.TPlo' \
depmode=gcc /bin/sh ../auxdir/depcomp \
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DSYSCONFFILE=\"/usr/local/etc/a2ps.cfg\" -I.. -I../intl -I.    -g -O2  -c -o path-concat.lo path-concat.c
gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DSYSCONFFILE=\"/usr/local/etc/a2ps.cfg\" -I.. -I../intl -I. -g -O2 -c path-concat.c -Wp,-MD,.deps/path-concat.TPlo -o path-concat.o
In file included from path-concat.c:30:
/usr/include/string.h:58: parse error before "void"
make[2]: *** [path-concat.lo] Error 1
make[2]: Leaving directory `/cygdrive/c/WINDOWS/Desktop/Downloads/Productivity/a2pstmp/a2ps-4.13/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/cygdrive/c/WINDOWS/Desktop/Downloads/Productivity/a2pstmp/a2ps-4.13'
make: *** [all-recursive-am] Error 2
Any help would be appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]