[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[a2ps] a2ps duplex and foomatic Duplexing

From: Jeremy C. Reed
Subject: [a2ps] a2ps duplex and foomatic Duplexing
Date: Thu, 12 Jan 2006 15:22:02 -0800 (PST)

I am not sure if this is a problem or if it is a problem whether it is in 
a2ps or foomatic or my printer itself.

I can print in duplex (and in duplex tumble) mode fine with my Brother 
HL-5150D printer using a foomatic script based on a BR5150_2.ppd. I just 
choose the foomatic script option Duplex_DuplexNoTumble or 

But when I use a2ps first to take two pages of my postscript document so 
it is placed on one side of the page, then my foomatic-based duplexing 
does not work -- it only printed on one side. (I wanted it to print four 
pages per sheet, but instead I got two pages on one side and the other 
side was blank.)

(I tried a few tests with different postscript files; they would not 
duplex print after processing with a2ps.)

Any ideas if this is a problem? Is the problem in a2ps, foomatic or my 

Then I used a2ps --sides=duplex and that in combination with the foomatic 
DuplexNoTumble option did print in duplex, but the back side was upside 

So I used a2ps --sides=tumble and that worked with foomatic's 
DuplexNoTumble and DuplexTumble -- they both behaved the same (printed 
same direction). This works for me!

And now I just printed (the --sides=tumble output) without the foomatic 
option (Duplex=None by default) and it still printed in duplex. foomatic 
endup seeing the a2ps created "Found: %%BeginFeature: *Duplex True".

For now I need to remember that when I use a2ps, I have to also remember 
to add the --sides=tumble (or =duplex) option if I want djuplex printing.

So to reexplain my situation. I use foomatic's duplex option to print in 
duplex unless I use a2ps on the postcript first. If I use a2ps, my 
foomatic duplexing does not work. I must use a2ps --sides=duplex (or 
=tumble) to print in duplex (but then it doesn't matter if I use 
foomatic's options for duplexing).

Is that normal?

I am using a2ps- package from pkgsrc and 

Please CC me on replies.

 Jeremy C. Reed

                         Media Relations and Publishing Services

reply via email to

[Prev in Thread] Current Thread [Next in Thread]