[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Arx-users] Fwd: Errors in the mirror command ? (Segmentation errors

From: Marc Recht
Subject: Re: [Arx-users] Fwd: Errors in the mirror command ? (Segmentation errors too)
Date: Mon, 17 Jan 2005 22:17:34 +0100

Hmm.  Looking through the code for gnome-vfs and boost, the only real
difference is that gnome-vfs uses POSIX "unlink" and "rmdir", while
boost uses Ansi C "remove".  So I tried replacing the call to "remove"

gnome-vfs also uses thread-safe functions (eg. readdir_r).

with "unlink" and "rmdir".  The initial get of arx.2.2,10 worked fine,
but getting arx.2.1,140 and merging in-place from there gave me the
same problems.  Can you do a merge and let me know if that works?

This works just fine with my patched 2.2,4 version[1].

Odd. I remember having a bug like that and then fixing it.  Is this
with 2.2,10?  Can you sprinkle srx/arx/commands/make_archive.cpp with
cout's to find out where it is having problem?

No, this was with 2.2,4. 2.2,10 seems to work fine. I'm currently forking your 2.2 archive (with 2.2,10 + patches) and rework the 2.2,4 patches (again) to that versions.


[1] But not with my patched 2.2,10 version. Which makes me believe that the patch I posted is somewhere wrong. I've attached the (verifed) patches against 2.2,4.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]