[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lcov version check in ax_code_coverage

From: Kevin Locke
Subject: lcov version check in ax_code_coverage
Date: Fri, 1 Jul 2016 10:03:01 -0700
User-agent: Mutt/1.6.0 (2016-04-01)

Hi Maintainers,

The ax_code_coverage macro checks that the selected lcov version
matches a version whitelist (1.6 to 1.11).  The current lcov version
(1.12) does not.  This could be fixed by adding it to the version
whitelist, but I would like your input on whether there is a better

The version check could be changed to "1.6 or greater", but given the
difficulty of parsing and comparing arbitrary version strings, I
wonder whether the check is really necessary.  I traced the macro
history back to its initial inclusion in Glib[1][2][3][4] when 1.6 was
the only whitelisted version, but couldn't find a rationale.  Since
the lcov/genhtml output is only used by the invoking user, I can't
think of a reason for the configure script to enforce version
requirements except as a matter of project policy (which wouldn't
apply to end users and should be set in by the caller
rather than hard-coded in ax_code_coverage anyway).

Should the version check be removed?  Changed to "1.6 or greater"?
Set by the caller?  Replaced by something else?  Or just add 1.12 to
the whitelist?

Thanks for considering,


Kevin Locke  |  address@hidden    | XMPP: address@hidden
             |  | IRC:   kevinoid on freenode

reply via email to

[Prev in Thread] Current Thread [Next in Thread]