[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SOLVED Re: Prefix bug in ax_lua?

From: Nate Bargmann
Subject: SOLVED Re: Prefix bug in ax_lua?
Date: Mon, 9 Apr 2018 07:12:01 -0500
User-agent: NeoMutt/20180223

* On 2018 08 Apr 22:50 -0500, Tim Perkins wrote:

Thanks for your help, Tim.

To answer your other email, I am running Slackware 14.2 with Lua 5.2/5.3
built from the scripts provided at and I am trying to
build bindings for my own SlackBuild script for Hamlib which now has Lua
language bindings available.

These are not distribution provided build scripts, but are submitted by
volunteers like myself.  I did find a bug in the respective
package-config files provided for each so those have been corrected.

The macro Hamlib is using is serial 39 which appears to differ only in
that URLs are http rather than https.

> Could you also try printing "package.path" from inside the Lua
> interpreter?

> print(package.path)

> print(package.path)

It looks like the bug is sitting right there!

> And maybe check if the LUA_PATH environment variable is being set
> somewhere?

No it's not, at least that I could find.

I dug into the build scripts for Lua and found that the path was being
modified in src/luaconfig.h and a trailing '/' was omitted in the sed
command.  I've corrected it locally and will be submitting a patch to
the script maintainers to correct this.  I have tested my local build of
Hamlib and the binding is now working correctly with the correct paths:

> print(package.path)

> print(package.path)

Which looks much better!

Thanks for your help in pointing me toward the right direction, which I
likely should have done first.

- Nate


"The optimist proclaims that we live in the best of all
possible worlds.  The pessimist fears this is true."

Web:  GPG key: D55A8819  GitHub: N0NB

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]