[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Last builtins to rename

From: Akim Demaille
Subject: Last builtins to rename
Date: 29 Nov 2000 17:12:23 +0100
User-agent: Gnus/5.0807 (Gnus v5.8.7) XEmacs/21.1 (Channel Islands)

~ace % m4 m4sugar.m4 =(echo "m4_dumpdef") |& grep -v '^_*m4_'| grep : 
__file__:       <__file__>
__line__:       <__line__>
            m4_defn([m4_location($1)])[: $1 is expanded from...])dnl
dnl:    <dnl>
ifelse: <ifelse>
        [m4_fatal([assert failed: $1], [$2])],
          [m4_errprintn(m4_location[: the top level])])
            m4_location[: $1 is required by...])dnl
         [m4_fatal([$0: circular dependency of $1])])dnl
          [m4_fatal([$0: cannot be used outside of an m4_defun'd macro])])dnl

I don't think the __macros__ should be renamed.  Remain ifelse and

I'd like to rename ifelse as m4_if, not m4_ifelse.  Does it sound OK?
All the if macros do have an else clause, but there is really no need
to emphasize it.

But in the case of `dnl', I'd like to know your opinions.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]