[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Akim Demaille
Subject: Re: FYI: AC_TRY_RUN
Date: 07 Feb 2001 12:25:48 +0100
User-agent: Gnus/5.0808 (Gnus v5.8.8) XEmacs/21.1 (Crater Lake)

Alexandre Oliva <address@hidden> writes:

> On Feb  6, 2001, Akim Demaille <address@hidden> wrote:
> > This fixes the 80 or 90 failures of the test suite due to the
> > inconsistent use of AC_TRY_COMMAND.  I hate this code :(
> > I'm applying it because it does no harm, and is private.
> Hmm...  I don't like AC_RUN_LOG.  It reminds me of AC_TRY_RUN, that
> servers a totally different purpose.  Unfortunately, I can't think of
> a better name that doesn't resemble AC_EVAL :-(

I agree very much.  We have a clash between the will to say EVAL in an
Autoconf sense, and eval in sh.  We are looking for a name that has a
Boolean flavor: it succeeds or fails.  Maybe we should walk in Lars'


Bleah.  The problem is we want to say something which precisely has no
name in Sh: just the act of running a command.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]