[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autoconf 2.53 doesn't find autom4te

From: Bruno Haible
Subject: Re: autoconf 2.53 doesn't find autom4te
Date: Thu, 13 Jun 2002 15:40:09 +0200 (CEST)

Akim Demaille writes:

> --prefix is there for the executables to find their files, because
> there is no such thing as PATH for these files.

So you agree that hardcoding pathnames for files which are not
executables is acceptable? Fine.

Now my situation was: I am interested in executing the autoconf
program from autoconf-2.53, so I made a symlink to a directory in my
PATH, and tried to invoke it. In the same PATH I also have an earlier
version of autoconf installed (namely 2.13).

I didn't do anything wrong:
  - I called "autoconf-2.53" which _is_ in my PATH.
  - I didn't call it as "autoconf" because the GNU coding conventions,
    as cited by Paul Eggert, give me the freedom to call them as I

But then autoconf tried to call the autom4te which I have in my PATH.
But that would be the version 2.13 of it, and it doesn't exist (or if
it had existed, it could have behaved differently than the version

The bottom line is: hardwiring paths helps against inadvertently
calling the wrong version of an auxiliary program.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]