[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Replace AC_FOREACH by m4_foreach_w

From: Stepan Kasal
Subject: Re: Replace AC_FOREACH by m4_foreach_w
Date: Thu, 26 May 2005 09:09:39 +0200
User-agent: Mutt/1.4.1i


On Wed, May 25, 2005 at 01:40:22PM -0700, Paul Eggert wrote:
> True, but it still bothers me a bit.  (I don't know whether the "w"
> stands for "word" or "white space".  :-)

actually, I had both in mind and I liked the ambiguity.

Perhaps you can find a better name for the macro?

> Also, will we need "_w" variants for other macros?  If so, I'd rather
> not maintain/describe pairs of macros, and it'd be better to factor
> out only the m4_split(m4_normalize([$1])) idiom rather than the
> m4_foreach(..., m4_split(m4_normalize([$1])), ...) idiom.

There is no occurence of m4_split(m4_normalize([$1])) which would be
outside m4_foreach, so I don't think the danger is big.

- We agree that AC_FOREACH should be obsoleted, and occurrences expanded.

- Then there is the question whether we should factor out m4_foreach_w.
  I still think it's good to factor, to increse readability, but I'm no
  longer so sure about it--I see your point, too.

Have a nice day,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]