[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AC_COMPUTE_INT's arguments

From: Ralf Wildenhues
Subject: Re: AC_COMPUTE_INT's arguments
Date: Sat, 2 Sep 2006 12:09:49 +0200
User-agent: Mutt/1.5.13 (2006-08-11)

Hello Bruno, Paul,

* Bruno Haible wrote on Fri, Sep 01, 2006 at 02:05:26PM CEST:
>     _AC_COMPUTE_INT([sizeof (ptrdiff_t) <= sizeof (int)], fits_in_int)

This example would benefit from a public AC_LANG_BOOL_COMPILE_TRY macro:
one compile test instead of three for the cross-compilation case.  But
that public version would have to include the cast to long int, for the
HP compiler, which would be at least a bit ugly.  Oh well, maybe best to
leave it as is for now.

* Paul Eggert wrote on Sat, Sep 02, 2006 at 07:40:31AM CEST:
> That being said, it's nice to have the convenience macro that does the
> commonly-needed thing.  Let's call it AC_CACHE_CHECK_INT since it's a
> combination of AC_CACHE_CHECK and AC_COMPUTE_INT; that's a better
> naming convention anyway.
> I've installed the following change into CVS, along those lines.
> Comments?

FWIW, that looks reasonable to me.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]