[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

recommend M4 1.4.7 for Autoconf

From: Paul Eggert
Subject: recommend M4 1.4.7 for Autoconf
Date: Mon, 25 Sep 2006 23:05:21 -0700
User-agent: Gnus/5.1008 (Gnus v5.10.8) Emacs/21.4 (gnu/linux)

I installed this:

2006-09-25  Paul Eggert  <address@hidden>

        * NEWS: Recommend M4 1.4.7 instead of 1.4.6.
        * README: Likewise.
        * doc/autoconf.texi (Introduction, Why GNU M4): Likewise.

Index: NEWS
RCS file: /cvsroot/autoconf/autoconf/NEWS,v
retrieving revision 1.400
diff -p -u -r1.400 NEWS
--- NEWS        2 Sep 2006 05:37:07 -0000       1.400
+++ NEWS        26 Sep 2006 05:57:38 -0000
@@ -13,6 +13,8 @@
   New macro, with the behavior of the 2.60a AC_COMPUTE_INT macro.
   AC_COMPUTE_INT no longer caches or reports results.
+** GNU M4 1.4.7 or later is now recommended.
 * Major changes in Autoconf 2.60a (2006-08-25)
 ** GNU M4 1.4.6 or later is now recommended.  At least one "make check"
RCS file: /cvsroot/autoconf/autoconf/README,v
retrieving revision 1.26
diff -p -u -r1.26 README
--- README      25 Aug 2006 17:23:12 -0000      1.26
+++ README      26 Sep 2006 05:57:38 -0000
@@ -11,15 +11,15 @@ operating system features that the packa
 macro calls.
 Producing configuration scripts using Autoconf requires GNU M4 and
-Perl.  You should install GNU M4 (version 1.4.6 or later) and Perl
+Perl.  You should install GNU M4 (version 1.4.7 or later) and Perl
 (5.005_03 or later) before configuring Autoconf, so that Autoconf's
 configure script can find them.  The configuration scripts produced by
 Autoconf are self-contained, so their users do not need to have
 Autoconf (or GNU M4, Perl, etc.).
-You can get GNU M4 1.4.6 here:
+You can get GNU M4 1.4.7 here:
 The file INSTALL should be distributed with packages that use
 Autoconf-generated configure scripts and Makefiles that conform to the
Index: doc/autoconf.texi
RCS file: /cvsroot/autoconf/autoconf/doc/autoconf.texi,v
retrieving revision 1.1085
diff -p -u -r1.1085 autoconf.texi
--- doc/autoconf.texi   13 Sep 2006 04:48:23 -0000      1.1085
+++ doc/autoconf.texi   26 Sep 2006 05:57:39 -0000
@@ -691,7 +691,7 @@ Autoconf imposes some restrictions on th
 Autoconf requires @acronym{GNU} M4 in order to generate the scripts.  It uses
 features that some versions of M4, including @acronym{GNU} M4 1.3,
-do not have.  You should use version 1.4.6 or later of @acronym{GNU} M4.
+do not have.  You should use version 1.4.7 or later of @acronym{GNU} M4.
 @xref{Autoconf 1}, for information about upgrading from version 1.
 @xref{History}, for the story of Autoconf's development.  @xref{FAQ},
@@ -18373,7 +18373,7 @@ __file__
 @end example
-Autoconf requires version 1.4.6 or later of @acronym{GNU} M4.
+Autoconf requires version 1.4.7 or later of @acronym{GNU} M4.
 Since only software maintainers need to use Autoconf, and since @acronym{GNU}
 M4 is simple to configure and install, it seems reasonable to require

reply via email to

[Prev in Thread] Current Thread [Next in Thread]