[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [GNU Autoconf 2.61] testsuite: 221 failed

From: Sam Sexton
Subject: RE: [GNU Autoconf 2.61] testsuite: 221 failed
Date: Tue, 16 Jan 2007 11:20:11 +0000


Thanks for the patch, but please acept my apologies - I applied it and
ran the test a few days ago, but have been distracted from this matter
ever since.  

As when I ran test 221 alone, I didn't get the problem, I ran the whole
(3-hour!) make check suite after the fix, but unfortunately, I got the
same problem reported.

However, as this doesn't affect our use of autoconf and I'm away on
holiday on Friday for a couple of weeks, I won't be available to try
again. Sorry.


Sam Sexton
Infrastructure Group
Transactions Group (Sales & Trading)
Reuters Messaging: address@hidden
(t) +44 24 7625 6562 | (m) +44 7990 563739 | (f) +44 24 7655 5203 

Get the latest news at

-----Original Message-----
From: Ralf Wildenhues [mailto:address@hidden 
Sent: 10 January 2007 23:27
To: Sam Sexton; Ian Macdonald
Cc: Peter Sandford; Christian Kreibich; address@hidden;
Subject: Re: [GNU Autoconf 2.61] testsuite: 221 failed

This is a followup to two related bug reports:

* Paul Eggert wrote on Wed, Jan 10, 2007 at 07:30:37AM CET:
> I cannot reproduce the problem on my Solaris 8 (sparc) host.

I can reproduce the problem on GNU/Linux with bash-3.2 (but not 3.1) and
on Solaris 8 with bash 2.03.0(1) but not on other Solaris versions
(which also happen to have different bash versions as /bin/bash).

This is how I can reproduce the issue interactively:
$ ./bash
bash$ f="1234567890
"; for i in 1 2 3 4 5 6 7 8 9 10 11 12; do f=$f$f; done; echo "$f" | sed

Weird though, I don't yet see an easy way to reproduce it

I did a rough check of the Autoconf sources, and I think the patch below
fixes the only instance of this issue, but am pretty certain that users'
macros and scripts are likely to contain more of those.

Could you please test whether this fixes the bug for you?
Ok to apply?


2007-01-10  Ralf Wildenhues  <address@hidden>

        * lib/autoconf/programs.m4 (AC_PROG_SED): When closing a pipe
        early on the reader side, drop stderr of the input to avoid
        `broken pipe' error output; this may happen even with shell
        builtin `echo' of some bash versions.
        Reports by Ian Macdonald <address@hidden> and Sam Sexton

Index: lib/autoconf/programs.m4
RCS file: /cvsroot/autoconf/autoconf/lib/autoconf/programs.m4,v
retrieving revision 1.63
diff -u -r1.63 programs.m4
--- lib/autoconf/programs.m4    17 Nov 2006 21:04:54 -0000      1.63
+++ lib/autoconf/programs.m4    10 Jan 2007 23:23:46 -0000
@@ -859,7 +859,7 @@
      for ac_i in 1 2 3 4 5 6 7; do
-     echo "$ac_script" | sed 99q >conftest.sed
+     echo "$ac_script" 2>/dev/null | sed 99q >conftest.sed
      $as_unset ac_script || ac_script=
      _AC_PATH_PROG_FEATURE_CHECK(SED, [sed gsed],
        [_AC_FEATURE_CHECK_LENGTH([ac_path_SED], [ac_cv_path_SED],

This email was sent to you by Reuters, the global news and information company. 
To find out more about Reuters visit

Any views expressed in this message are those of the individual sender, except 
where the sender specifically states them to be the views of Reuters Ltd.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]