[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make check hangs on test 93 under Sun Solaris 9

From: Ralf Wildenhues
Subject: Re: make check hangs on test 93 under Sun Solaris 9
Date: Tue, 6 Feb 2007 19:52:06 +0100
User-agent: Mutt/1.5.13 (2006-08-11)

Hello Ralf,

* Ralf Menzel wrote on Tue, Feb 06, 2007 at 03:07:46PM CET:
> I tried to run 'make check' on a recent CVS checkout of autoconf, but
> it hung on test 93: AC_ARG_VAR. I could trace this back to the patch
> made to lib/autoconf/status.m4 on 2007-01-19. Without this patch all
> tests work fine.
> I tried to investigate the problem. What I found is that /usr/bin/awk
> waits for input from stdin when invoked like this:
>   /usr/bin/awk 'BEGIN { print 1 }'

Thanks for the report and patch.  I applied it; due to the ^M, your
message contained a mangled patch, but I assume that all you added was

Hmm, apparently I overlooked at the time that this is documented in the
gawk manual (Using BEGIN/END):

| If an `awk' program has only a `BEGIN' rule and no other rules, then
| the program exits after the `BEGIN' rule is run.(1)
| (1) The original version of `awk' used to keep reading and ignoring
| input until the end of the file was seen.


2007-02-06  Ralf Menzel  <address@hidden>  (tiny change)

        * lib/autoconf/status.m4 (_AC_OUTPUT_FILES_PREPARE): Redirect
        input from /dev/null in awk test, so even Solaris /usr/bin/awk
        will not wait for input with a script containing only a BEGIN

reply via email to

[Prev in Thread] Current Thread [Next in Thread]