[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: docs: document several Fortran and OpenMP cache variables.

From: Ralf Wildenhues
Subject: Re: docs: document several Fortran and OpenMP cache variables.
Date: Sat, 5 Mar 2011 18:57:11 +0100
User-agent: Mutt/1.5.20 (2010-08-04)

Hello Paul,

* Paul Eggert wrote on Sat, Mar 05, 2011 at 06:13:54PM CET:
> On 03/05/2011 08:35 AM, Ralf Wildenhues wrote:
> > The only one I think looks kinda odd in hindsight is
> > ac_cv_prog_c_openmp
> How about if we rename that to ac_cv_prog_cc_openmp, then?
> Might as well do it now, before it escapes.

Sorry, I obviously totally failed to convey the point, as I forgot half
of the issue.  AC_OPENMP correctly uses _AC_LANG_ABBREV to set the
language part of the cache variable name.  For C, that is defined as 'c'
as per the AC_LANG_DEFINE call in c.m4.  It's just that most of the
other ac_cv_prog_* cache variables that deal with C compiler issues use
cc rather than _AC_LANG_ABBREV.

So, that macro is actually correct, technically.  Just looks a bit weird
when looking at the cache variable index.

The other cache variables have been used (and documented) for a longer
time, so I don't think it's a good idea to rename just for the sake of


reply via email to

[Prev in Thread] Current Thread [Next in Thread]