[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: building same source with different flag

From: Ted Irons
Subject: Re: building same source with different flag
Date: Wed, 26 Dec 2001 21:00:44 -0700

My first post involved using automake-1.5b.  I have
subsequently tried the same thing using automake-1.5.
The error message was the same.

- Ted

P.S. Automake-1.5b seems to exhibit other peculiarities -
like picking up shared libraries from the wrong place.
When I get back to automake-1.5b, I'll document this

Am using autoconf-2.5.2, automake-1.5b, libtool-1.4b
on an ix86 box run running Suse Linux with kernel-2.4.6.

My contains the following  snippets:

libhrnet_la_SOURCES =

libhrnet_la_CXXFLAGS = ${HBP_CXXFLAGS}

libhrnet_la_LDFLAGS = -version-info @PIPES_VERSION@

libohrnet_la_SOURCES =


libohrnet_la_LDFLAGS = -version-info @PIPES_VERSION@


When I run make I get the following error:

source='' object='libhrnet_la-ascbin.lo' libtool=yes \
tmpdepfile='.deps/libhrnet_la-ascbin.TPlo' \
depmode=gcc /bin/sh ../../../pipes-1.0/config/depcomp \
/bin/sh ../../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. 
-I../../../pipes-1.0/tma/hbp.lib -I../..    -fpermissive
-I../../../pipes-1.0/tma/util.lib -I../../../pipes-1.0/tma/trff.lib -g -O2 -c 
-o libhrnet_la-ascbin.lo `test -f || echo
g++ -DHAVE_CONFIG_H -I. -I../../../pipes-1.0/tma/hbp.lib -I../.. -fpermissive 
-I../../../pipes-1.0/tma/trff.lib -g -O2 -c 
../../../pipes-1.0/tma/hbp.lib/ -Wp,-MD,.deps/libhrnet_la-ascbin.TPlo
mv -f libhrnet_la-ascbin.o .libs/libhrnet_la-ascbin.o
mv: cannot stat `libhrnet_la-ascbin.o': No such file or directory
make[3]: *** [libhrnet_la-ascbin.lo] Error 1


Any ideas as to what I am doing wrong?

Thanks in advance,
- Ted

reply via email to

[Prev in Thread] Current Thread [Next in Thread]