[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Dashes in library names

From: McKenzie Keith
Subject: Dashes in library names
Date: Fri, 22 Aug 2003 22:58:12 -0700

I am not an advanced autotools guy. If this question is misguided in some way, I apologize, but it appears to me to be a legitimate automake question.

I am trying to create a couple of libraries with dashes in the name. When I tried the obvious in my, automake complained about bad macros. Here is an example of what I tried:



libswt-gtk-2052_la_SOURCES = \
callback.h callback.c

libswt-pi-gtk-2052_la_SOURCES = \
structs.h swt.h structs.c swt.c

libswt-gtk-2052_la_CFLAGS = -DSWT_VERSION=2052
libswt-pi-gtk-2052_la_CFLAGS = $(GTKDEPS_CFLAGS) -DSWT_VERSION=2052

libswt-pi-gtk-2052_la_LDFLAGS = $(GTKDEPS_LIBS)


When I change the dashes to underscores, I have no problem (except that I am not getting the library name that I need).

I am using automake 1.6.3, autoconf 2.53, and libtool 1.4.2.

Any suggestions as to how to best get what I want would be much appreciated.


Get MSN 8 and help protect your children with advanced parental controls.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]