automake
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: output7.test failure


From: Patrick Welche
Subject: Re: output7.test failure
Date: Sun, 26 Oct 2003 15:38:13 +0000
User-agent: Mutt/1.3.19i

On Sat, Oct 25, 2003 at 11:49:43PM +0200, Alexandre Duret-Lutz wrote:
> >>> "Patrick" == Patrick Welche <address@hidden> writes:
>  Patrick> All attached.. There is plenty of sed between
>  Patrick> "creating Makefile" and "creating sub/Makefile" :(
> 
> That was a wrong track.  
> 
> The problem is with tar.  Old versions of tar do not archive
> empty directories when passed the `o' flag.  (In our case sub/ is
> an empty directory, and in your initial report it is missing
> from the source directory.  Hence the failure.)
> 
> This behavior of tar was corrected some time ago:
> 
> | 1997-02-25  Fran├žois Pinard  <address@hidden>
> | 
> |         * create.c (dump_file): Allow saving directories even with -o.
> |         Reported by Daniel Trinkle.
> 
> Version 1.12 was released on 1997-04-25 with this fix.
> 
> Apparently NetBSD 1.6.1 still ships with GNU tar 1.11.2 (which
> is ten year old), so it has an -o flag that excludes empty
> directories, hence the failure.

Good work! In my case the story is even a little stranger - I'm running
NetBSD-current, where tar is a hard link to pax. I suppose the tar front
end to pax is taking "-o" to be "work exactly like really old tar" :)
Something to change..

Cheers,

Patrick




reply via email to

[Prev in Thread] Current Thread [Next in Thread]