[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tools under Windows

From: BRM
Subject: Re: Tools under Windows
Date: Sat, 10 Dec 2005 11:35:04 -0800 (PST)

--- David Boreham <address@hidden> wrote:
> >Does anyone know of a project that could help solve
> >the problem? I guess, I am primarily looking for a
> >non-intrusive cmd.exe replacement for Windows 2000
> >Pro.
> Are you trying to avoid installing Cygwin for your
> build
> environment, or avoid Cygwin in your runtime
> environment ?
> If the latter, then there is a workable option for
> you that
> we use in a project here:
> This allows you to build with the autoconf tools,
> but
> use the MS compiler, and hence avoid a runtime
> dependency on Cygwin.

I wouldn´t mind using Cygwin as the build environment.
What I mind is having to have any dependancy from the
Cygwin build environment come into my project. As much
as I may like to, I can´t open source the project (not
my call to do so), and my customers won´t install
anything from Cygwin.

Since this is a commercial app, I probably have to
avoid other dependancies as well; so I´d like to try
to eliminate Cygwin from the build and runtime

My preference would be to run ´make´ at the standard
Windows command prompt (cmd.exe). This is doable with
GnuWin32, but I´d also like to be running autoconf,
and automake - which isn´t so doable with GnuWin32 as
I discovered, primarily because they use perl to run
which (a) seems to be lacking WIFEXITED, and (b)
Windows doesn´t know how to execute shell scripts
without associating extensions with them.

I tried building a little environment to allow the
scripts to run. I got it to detect them, and execute
them, but then ran into the problem that Perl has
cmd.exe hard-coded instead of referencing %COMSPEC%
(like it should) so any script it tries to execute
after the primary one won´t run since cmd.exe is
stored in %WINDIR%\System32 and I can´t replace it. 

I´m taking a look at Msys/MingW now. Its worked best
so far - though a script is failing. I got it to run
by running the VC build environment (e.g. vcvars.bat)
and then running the msys environment (msys.bat) to
enter into the msys shell.

Thanks for the tip on cccl. I´ll be sure to look into
that too; may be its a combination of the two.



TCP/IP Evil-bit RFC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]