[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

running tests with automake on windows with mingw...

From: Ed Hartnett
Subject: running tests with automake on windows with mingw...
Date: Wed, 26 Jul 2006 15:16:52 -0600
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.4 (gnu/linux)

Howdy Automakers!

I have finally gotten my library to build under mingw on windows,
which is great, but there is a problem running the test programs.

For each test program, on windows I get both an exe file and a shell

For example, with the test program t_nc.c, which on unix will end up
as an executable t_nc, on windows I get an executable, t_nc.exe, and a
shell script, t_nc.

When I call the shell script, it works great. But when I run "make
check" it doesn't call the shell script. It calls the .exe file, and
that fails:

libtool: link: gcc -g -O2 -o .libs/t_nc.exe t_nc.o
./.libs/libnetcdf.dll.a -L/usr/local/lib
libtool: link: creating t_nc.exe
make[2]: Leaving directory `/c/cygwin/home/ed/netcdf-3/libsrc'
make  check-TESTS
make[2]: Entering directory `/c/cygwin/home/ed/netcdf-3/libsrc'
FAIL: t_nc.exe

However, if I run the t_nc script, directly from the command line, all
works as expected:

$ libsrc/t_nc
dimrename: IXX
nc_close ret = 0

reopen id = 3 for filename
NC done

So how do I get automake to use the shell script, and not the .exe,
when it builds the Makefile that runs the tests?



Ed Hartnett  -- address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]