[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Difficulty cross-compiling

From: William Tracy (wtracy)
Subject: Difficulty cross-compiling
Date: Mon, 12 Oct 2009 11:26:03 -0700



I'm trying to cross-compile a library that uses GNU Autotools (Google
Coredumper, to be specific) for PPC using the MontaVista tool chain. The
sequence of commands I'm following is:


$ ./configure --host=ppc CC=/path/to/gcc CXX=/path/to/g++ 

$ make 

$ [next step would normally be "make install"]


For a normal (not cross-compile) configuration, issuing "make" causes a
.libs/ directory to be generating containing .a, .o, and .so files (and
variants thereof). When I cross-compile for PPC, the directory is
created and populated with a .a file, but no .so files. I can see .o and
.lo files being generated, so the code *is* getting compiled, but the
linking stage gets skipped. When I review the make output, there are no
error messages or warnings-the commands related to the .so files are
simply missing.


I've tried additionally manually specifying paths for the other
components of the GNU toolchain (linker, assembler, etc.) and, at the
suggestion of the people on the CLFS mailer, I've tried running
./configure with -enable-shared="yes" -enable-static="no". None of these
suggestions have helped.


*Summary*: When I try to cross-compile, make mysteriously and silently
skips one or more parts of the build. (If I build for the same
architecture, it works fine.)


I've tried diff-ing the Makefiles generated by ./configure for the
different architectures, and they look the same (other than the paths to
the compiler executables being different). I've also tried grepping the
Makefiles for the relevant commands that I see in the output; I get no
matches in either Makefile, so Autotools is doing something arcane here.


Any input would be appreciated.



William Tracy


reply via email to

[Prev in Thread] Current Thread [Next in Thread]