[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: converting to subdir-objects

From: Gavin Smith
Subject: Re: converting to subdir-objects
Date: Sun, 8 Mar 2015 11:08:25 +0000

On 8 March 2015 at 09:46, Harlan Stenn <address@hidden> wrote:
> I've got an "old style" build tree and I'm trying to convert it to use
> subdir-oobjects.
> I've got a good number of subdirs in this project, and some of these
> subdirs contain source files but no (or derivatitives).
> The problem I'm seeing (with at least automake-1.12.1 and automake-1.15)
> is that the .deps directories are not being created along the subdir
> path, so the build is failing.
> So if A/ contains:
>  foo_SRCS = ... $(srcdir)/../foo/bar.c
> I eventually see:
> Makefile:XXX: ../../mydir/../foo/.deps/bar.Po: No such file or dierctory
> I get this behavior with both FreeBSD's make and with gmake.  I am using

I managed to get the same error. My test case is attached (is actually
a .tar.gz file).

First I tried it with an older development version I had installed
(reporting itself as "automake 1.99a"), and it worked. Then I
downloaded and installed automake 1.15, and this happens.

After running "./configure" and "make":
Making all in A
make[1]: Entering directory `/home/g/src/test-case/A'
Makefile:342: ../foo/.deps/bar.Po: No such file or directory
make[1]: *** No rule to make target `../foo/.deps/bar.Po'.  Stop.
make[1]: Leaving directory `/home/g/src/test-case/A'
make: *** [all-recursive] Error 1

A "$(srcdir)" directory exists under A.

Attachment: test-case.-nottargz
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]