bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH] master: remove useless variable.


From: Akim Demaille
Subject: [PATCH] master: remove useless variable.
Date: Tue, 19 May 2009 11:29:40 +0200

        * src/getargs.c (skeleton_arg): Remove now useless variable.
        Should help the compiler see that this printf-like call is sane.
---
 ChangeLog     |    6 ++++++
 src/getargs.c |    6 +-----
 2 files changed, 7 insertions(+), 5 deletions(-)

diff --git a/ChangeLog b/ChangeLog
index 71cf3a8..9ae746f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2009-05-19  Akim Demaille  <address@hidden>
+
+       remove useless variable.
+       * src/getargs.c (skeleton_arg): Remove now useless variable.
+       Should help the compiler see that this printf-like call is sane.
+
 2009-05-15  Akim Demaille  <address@hidden>
 
        Rename token.prefix as api.tokens.prefix.
diff --git a/src/getargs.c b/src/getargs.c
index e5b016a..6f95692 100644
--- a/src/getargs.c
+++ b/src/getargs.c
@@ -385,11 +385,7 @@ skeleton_arg (char const *arg, int prio, location loc)
       skeleton = arg;
     }
   else if (prio == skeleton_prio)
-    {
-      char const *msg =
-       _("multiple skeleton declarations are invalid");
-      complain_at (loc, msg);
-    }
+    complain_at (loc, _("multiple skeleton declarations are invalid"));
 }
 
 void
-- 
1.6.3





reply via email to

[Prev in Thread] Current Thread [Next in Thread]