bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 2/6] todo: remove erroneous task


From: Akim Demaille
Subject: [PATCH 2/6] todo: remove erroneous task
Date: Thu, 3 Jan 2013 15:05:46 +0100

* tests/input.at: Check that there are no warnings about stray $ and @
in the epilogue.
* TODO: Remove the correponding task.
---
 TODO           | 4 ----
 tests/input.at | 9 ++++++---
 2 files changed, 6 insertions(+), 7 deletions(-)

diff --git a/TODO b/TODO
index e8509e3..2a08164 100644
--- a/TODO
+++ b/TODO
@@ -43,10 +43,6 @@ back-ported.
     yytoken = yytranslate_ (yychar);
 
 
-** $ and others in epilogue
-A stray $ is a warning in the actions, but an error in the epilogue.
-IMHO, it should not even be a warning in the epilogue.
-
 ** stack.hh
 Get rid of it.  The original idea is nice, but actually it makes
 the code harder to follow, and uselessly different from the other
diff --git a/tests/input.at b/tests/input.at
index 385d0f3..44a2477 100644
--- a/tests/input.at
+++ b/tests/input.at
@@ -1668,19 +1668,22 @@ AT_DATA_GRAMMAR([[input.y]],
 %destructor     { $%; @%; } <*> exp TOK;
 %initial-action { $%; @%; };
 %printer        { $%; @%; } <*> exp TOK;
+%{ $ @ %} // Should not warn.
 %%
 exp: TOK        { $%; @%; $$ = $1; };
+%%
+$ @ // Should not warn.
 ]])
 
-AT_BISON_CHECK([[input.y]], 0, [],
+AT_BISON_CHECK([[-Wall input.y]], 0, [],
 [[input.y:11.19: warning: stray '$' [-Wother]
 input.y:11.23: warning: stray '@' [-Wother]
 input.y:12.19: warning: stray '$' [-Wother]
 input.y:12.23: warning: stray '@' [-Wother]
 input.y:13.19: warning: stray '$' [-Wother]
 input.y:13.23: warning: stray '@' [-Wother]
-input.y:15.19: warning: stray '$' [-Wother]
-input.y:15.23: warning: stray '@' [-Wother]
+input.y:16.19: warning: stray '$' [-Wother]
+input.y:16.23: warning: stray '@' [-Wother]
 ]])
 
 AT_CLEANUP
-- 
1.8.0.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]