[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autoconf problem building

From: Tim Van Holder
Subject: Re: autoconf problem building
Date: 12 Feb 2002 08:43:56 +0100

On Mon, 2002-02-11 at 23:06, Eurico de Sousa wrote:
> I added </dev/null (in aclocal.m4 I presume) as suggested, but it still hangs 
> on the configure. I
> don't know much about it as I don't use it, but it doesn't seem to accept any 
> options I give it,
> like -help, --version, -v, -V. When I run emacs, I can't CTRL-C out of it to 
> get back to the shell -

That's expected; the normal way to exit emacs is 'CTRL-X CTRL-C', not
just CTRL-C.

> it hangs - I have to kill the cmdtool (Solaris 2.6/7/8). If I run 
> emacs</dev/null, I can CTRL-C out
> of it. Unfortunately, I don't have any man pages for it. However, I just 
> noticed we have a very old
> version of MicroEmacs - I have MicroEmacs 3.6 installed (1990!!).


> I will try installing the latest version and rebuild autoconf. Should this 
> make a difference do you
> think?

If it's Jasspa MicroEmacs you have installed, it would help (the current
version for Linux seems to exit with an error if it encounters an
unknown command-line option; I expect the Solaris version would do the
same).  Not sure about other types of MicroEmacs.
In any case, you can avoid the test (and the hang) altogether by either
passing the '--without-lispdir' option to configure, or setting the
environment variable EMACS to 'no' before running configure.

But the main point is that if your emacs doesn't support GNU Emacs-style
command-line options and/or Emacs Lisp, there's no point in us trying to
use it that way.  Especially since we might not be able to detect if
someone is using (an old) MicroEmacs, with the.

*sigh* Then again, I've seen systems where 'emacs' is a symlink to vi,
so I guess this isn't all that bad :-)

Unless there are other suggestions, I'll add the /dev/null to the
lispdir macro in aclocal.m4 and Automake (at least the test can then be

I'll also add an entry to Autmake's docs warning that the lispdir macro
can fail badly when 'emacs' isn't GNU Emacs or XEmacs.

Is it worth it to have the lispdir macro print a message like 'If this
test takes a long time, you may have a bad or incompatible emacs. 
Please kill this script and rerun it with the --without-lispdir

reply via email to

[Prev in Thread] Current Thread [Next in Thread]