[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with groff's configure script on z/OS Unix

From: Michael MacIsaac
Subject: Re: Problem with groff's configure script on z/OS Unix
Date: Tue, 12 Feb 2002 13:02:10 -0500


> Could that person try a simple:
> ~/src/tiger % cat /tmp/foo.sh                                    nostromo
> #! /bin/sh
> exec 5> /tmp/foo.log
> echo foo >&5
> cat /tmp/foo.log

$ cat /tmp/foo.sh
#! /bin/sh

exec 5> /tmp/foo.log
echo foo >&5
$ /tmp/foo.sh
$ cat /tmp/foo.log

> ~/src/tiger % sh -x /tmp/foo.sh                                  nostromo
> + exec
> + echo foo
> + cat /tmp/foo.log
> foo

$ sh -x /tmp/foo.sh
+ exec
+ 5> /tmp/foo.log
+ echo foo
+ 1<& 5
address@hidden> cat /tmp/foo.log

> If this fails, I'd like to know the reason of the failure.  We are in
> a deep s*t, IMHO.  Because it means we have to move to another fd,
> which means... that you want us to move to a fd, say 7, which we
> *never* tried to use before.  In other words, to please this machine,
> you're asking us to take risks on possibly many others :(

Looks OK to me.

> Just a question...  Someone did make sure, say via `sh -x
> ./configure', that the exec 5>config.log was indeed performed, right?
No I didn't.
But I just added "sh -x" in my install script, and now ./configure is
running. Also, I moved the exact code to Linux (SuSE 7.2 on PC server)
and tried basically the same install script (without the sh -x) and it
ran fine.

So it *seems* this is another strange OS/390 UNIX problem.

          -Mike MacIsaac,  IBM   address@hidden   (845) 433-7061

reply via email to

[Prev in Thread] Current Thread [Next in Thread]