[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ./configure -C creates config.cache it can't use

From: Matt McClure
Subject: Re: ./configure -C creates config.cache it can't use
Date: Sun, 30 Jun 2002 21:20:31 -0400
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Paul Eggert wrote:
>>From: Matt McClure <address@hidden>
>>Date: Fri, 28 Jun 2002 12:22:28 -0400
>>On IRIX 6.5, I bootstrap with:
>>libtoolize --force --copy \
>>&& aclocal \
>>&& autoheader \
>>&& automake --foreign --add-missing --copy \
>>&& autoconf
>>and then run:
>>./configure -C
>>If I run configure again, it says:
>>bash-2.05$ ./configure -C
>>configure: loading cache config.cache
>>./configure[1290]: syntax error at line 76 : `(' unexpected
> Can you please give more context?  I can't reproduce the bug with just
> that information; I need to have a configure.ac, for example.
> (I just tried a trivial configure.ac, and didn't reproduce the problem.)

A pretty trivial example causes the problem for me:

bash-2.05$ ls
Makefile.am   configure.in  foo.c
bash-2.05$ cat configure.in

AM_INIT_AUTOMAKE(libfoo, 0.0.0)

bash-2.05$ cat Makefile.am
lib_LTLIBRARIES = libfoo.la

libfoo_la_SOURCES = foo.c
bash-2.05$ cat foo.c
void foo() {

bash-2.05$ libtoolize --force --copy
You should add the contents of `/usr/freeware/share/aclocal/libtool.m4'
to `aclocal.m4'.
bash-2.05$ aclocal
bash-2.05$ automake --foreign --add-missing --copy
configure.in: installing `./install-sh'
configure.in: installing `./mkinstalldirs'
configure.in: installing `./missing'
Makefile.am: installing `./depcomp'
bash-2.05$ autoconf
bash-2.05$ ./configure -C
configure: creating cache config.cache
checking for a BSD-compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking build system type... mips-sgi-irix6.5
checking host system type... mips-sgi-irix6.5
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking dependency style of gcc... gcc
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependant libraries... pass_all
checking command to parse /usr/bin/nm -B output... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... no
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for ranlib... :
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... none
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld -n32) supports shared
libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... no
checking dynamic linker characteristics... irix6.5 ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether -lc should be explicitly linked in... yes
creating libtool
updating cache config.cache
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands
bash-2.05$ ./configure -C
configure: loading cache config.cache
./configure[1280]: syntax error at line 62 : `(' unexpected

It looks like the offending sed command is being requoted and escaped
differently on IRIX than it is on Linux.


test "${lt_cv_global_symbol_to_c_name_address+set}" = set ||
lt_cv_global_symbol_to_c_name_address='sed -n -e '\''s/^\'^: \([^\'^
]*\) $/  {\"\1\", (lt_ptr) 0},/p'\'' -e '\''s/^\'^[BCDEGRST] \([^\'^
]*\) \([^\'^ ]*\)$/  {"\2", (lt_ptr) \&\2},/p'\'


test "${lt_cv_global_symbol_to_c_name_address+set}" = set ||
lt_cv_global_symbol_to_c_name_address='sed -n -e '\''s/^: \([^ ]*\) $/
{\"\1\", (lt_ptr) 0},/p'\'' -e '\''s/^[BCDEGRST] \([^ ]*\) \([^ ]*\)$/
{"\2", (lt_ptr) \&\2},/p'\'''

Note the \'^ that is getting added to the IRIX version after /^ and
after [^, and the two ' missing from the end of the IRIX version.

In both cases, the line in aclocal.m4 that creates the above lines in
config.cache are:

lt_cv_global_symbol_to_c_name_address="sed -n -e 's/^: \([[^ ]]*\) $/
{\\\"\1\\\", (lt_ptr) 0},/p' -e 's/^$symcode \([[^ ]]*\) \([[^ ]]*\)$/
{\"\2\", (lt_ptr) \&\2},/p'"

Can you reproduce this?

When I invoke configure, what tool in the chain does the requoting and
escaping of the above line from aclocal.m4?



    When you move like a jellyfish
    Rhythm don't mean nothing
        -Jack Johnson

Attachment: pgpPT5rQAGMpF.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]