[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

make check hangs on test 93 under Sun Solaris 9

From: Ralf Menzel
Subject: make check hangs on test 93 under Sun Solaris 9
Date: Tue, 06 Feb 2007 15:07:46 +0100
User-agent: Gnus/5.1007 (Gnus v5.10.7) XEmacs/21.4.19 (usg-unix-v)


I tried to run 'make check' on a recent CVS checkout of autoconf, but
it hung on test 93: AC_ARG_VAR. I could trace this back to the patch
made to lib/autoconf/status.m4 on 2007-01-19. Without this patch all
tests work fine.

I tried to investigate the problem. What I found is that /usr/bin/awk
waits for input from stdin when invoked like this:

  /usr/bin/awk 'BEGIN { print 1 }'

I therefore tried the following patch that seems to work for me

--- snip ---
Index: lib/autoconf/status.m4
RCS file: /cvsroot/autoconf/autoconf/lib/autoconf/status.m4,v
retrieving revision 1.127
diff -u -p -r1.127 status.m4
--- lib/autoconf/status.m4      19 Jan 2007 06:54:34 -0000      1.127
+++ lib/autoconf/status.m4      6 Feb 2007 13:37:52 -0000
@@ -363,7 +363,7 @@ else
   ac_cs_awk_pipe_fini='END { print "|#_!!_#|" }'
-ac_cs_awk_cr=`$AWK 'BEGIN { print "a
b" }' 2>/dev/null`
+ac_cs_awk_cr=`$AWK 'BEGIN { print "a
b" }' </dev/null 2>/dev/null`
 if test "$ac_cs_awk_cr" = 'a
b'; then ac_cs_awk_cr=; else ac_cs_awk_cr='\\'; fi
 dnl Define the pipe that does the substitution.
--- snip ---

Ralf Menzel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]