[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Autoconfig bug report

From: JohnT
Subject: Autoconfig bug report
Date: Tue, 09 Oct 2007 15:05:30 -0500
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070802 SeaMonkey/1.1.4

Here are a few observations on using the autoconfig 2.61 package.

autoupdate 2.61 doesn't handle version info correctly. It puts the following 

        Libgpg-error vmy_versionm4_if(no,yes,-svn0) has been configured as 

into the config.ac or config.in file that results in the configure script giving
the above output instead of a correct version number for a standard release. 
happened for the two packages I tried running autodate on, parts of the 
package including the current libgcrypt, libassuan, libksba and libgpg-error 
The standard configure file for libgpg-error-1.5 worked fine, and the config.ac 
was processed correctly by autoconfig to produce an evidently good configure 
that resulted in an evidently good Makefile, but running autoupdate produced a 
config.ac file that became a bad configure script that made a Makefile with the
correct version info missing and the script text displayed instead.

Autoconfig reported the following error on processing the configure.ac file for 
gpg 2.0.7 which configured, "made" and compiled OK with the configure file 
in the release. 

address@hidden gnupg-2.0.7]# autoconf --output=configure
configure.ac:883: warning: AM_INTL_SUBDIR is m4_require'd but not m4_defun'd
m4/gettext.m4:362: AM_GNU_GETTEXT is expanded from...
configure.ac:883: the top level
configure:10400: error: possibly undefined macro: AM_INTL_SUBDIR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.


John in Salina, KS USA


reply via email to

[Prev in Thread] Current Thread [Next in Thread]