[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autoconf-2.62 doesn't build on RHEL4

From: Ralf Corsepius
Subject: Re: autoconf-2.62 doesn't build on RHEL4
Date: Mon, 21 Apr 2008 15:32:15 +0200

On Mon, 2008-04-21 at 06:55 -0600, Eric Blake wrote:
> Hash: SHA1
> According to Ralf Corsepius on 4/21/2008 3:12 AM:
> |> checking for GNU M4 that supports accurate traces...
> |> configure: error: no acceptable m4 could be found in $PATH.
> |> GNU M4 1.4.5 or later is required; 1.4.11 is recommended
> |
> | RHEL 4 still ships an antiquated m4-1.4.1
> |
> | (Time for me to abandon supporting RHEL-4, I suppose ;)
> Or manually install a newer m4 on that platform yourself.  Our decision to
> require newer m4 is intentional, as older m4 have bugs that can cause
> autoconf to create broken configure output.
Technically true, but ... replacing a central tool like m4 from a distro
aiming at long term stability isn't necessarily a clever idea :/

I regret having to say so, but to me this has several implications:
* RHEL and other "LTS distros" disqualify as development platforms.
* Packages using autoconf will stay with outdated versions of autoconf
because maintainers of "LTS" distros will refuse to install the
infrastructure required by newer autoconfs.
* Package vendors/distributors are being forced to find work-arounds to
allow their customers/users to use their projects.

For the moment, I have decided stay with autoconf-2.61 for our works to
avoid this kind of hassle  :(


reply via email to

[Prev in Thread] Current Thread [Next in Thread]