[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't use Fortran 90/95 compiler for F77

From: Ralf Wildenhues
Subject: Re: Can't use Fortran 90/95 compiler for F77
Date: Wed, 4 Nov 2009 19:33:28 +0100
User-agent: Mutt/1.5.20 (2009-08-09)

Hello Jeff,

thanks for your reply.  Please keep the mailing list in Cc:, so that
others can see, too, and please don't top-post.  Thanks.

* Daily, Jeff A wrote on Wed, Nov 04, 2009 at 05:25:37PM CET:
> From: Ralf Wildenhues:
> > First, does using
> >   ./configure F77="f77 -qfixed"
> > 
> > work, when you replace f77 with your compiler name?
> > 
> > Then, can you try this, and show all output plus config.log?  Thanks.
> > 
> > cat >configure.ac <<\EOF
> > AC_PROG_F77
> > AC_FC_SRCEXT([f])
> > EOF
> > autoconf
> > ./configure

> Adding "-qfixed" worked.  Curiously, removing it also worked this
> morning.  Please ignore my message unless the problem manifests again.
> This likely has more to do with BlueGene/P using a cross-compiler and my
> unfamiliarity with that system.

OK.  Well, if you come across this again, just perform the actions I
noted and report back.  IIRC then the compiler should accept fixed
format if the file has ending .f and the compiler is invoked as "f77",
so it might just be you used a different alias name for it before.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]