[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Autoconf requires m4 and m4 requires autoconf

From: Eric Blake
Subject: Re: Autoconf requires m4 and m4 requires autoconf
Date: Sat, 02 Jan 2010 11:06:03 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20090812 Thunderbird/ Mnenhy/

Hash: SHA1

According to Chris Karakas on 1/2/2010 8:53 AM:
> To whom this may concern:
> This is an utmost annoying bug:

It is NOT a bug.

>   ...but m4 will NOT let you compile it, unless you have an upgraded autoconf:
>   + autoreconf --force --install
>   configure.ac:20: error: Autoconf version 2.60 or higher is required

Bleeding-edge development m4.git will not let you compile it, unless you
have upgraded autoconf.  But _released_ m4 packages, such as m4 1.4.13, do
NOT depend on autoconf (that is, you should NOT need to run autoreconf in
order to build m4 from an existing tarball).  So, before trying to do any
bleeding edge development on either project, you should _first_ install
the latest released versions (m4 1.4.13 and autoconf 2.65).

> m4-1.4o-504

That is an experimental cut of bleeding edge m4, but it is so old that it
does NOT support the features required by current autoconf.  I'm not sure
if the -504 implies that your distro has patched all the security holes,
but the original m4-1.4o tarball had a number of security holes which have
since been patched in m4.git.  But I do wish I had more time to work
towards release m4 1.6, which would expose several of the features present
in m4-1.4o but not in 1.4.x.

- --
Don't work too hard, make some time for fun as well!

Eric Blake             address@hidden
Version: GnuPG v1.4.9 (Cygwin)
Comment: Public key at home.comcast.net/~ericblake/eblake.gpg
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


reply via email to

[Prev in Thread] Current Thread [Next in Thread]