[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash builtin test changes in 2.04

From: Andreas Schwab
Subject: Re: bash builtin test changes in 2.04
Date: Mon, 9 Oct 2000 12:59:19 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.90

address@hidden (Bill Unruh) writes:

|> There seems to have been a change in teh behaviour of the bash builtin
|> test or [
|> In particular, the ( EXPRESSION ) syntax seems to have changed so that
|> [ ! ( -z "$USER" -o -z $PS1 ) ] 
|> gives and error when it worked in 2.03. It forthermore works for the gnu
|> /usr/bin/test. Has tehre been a change and why?

I doubt it has ever worked, because `(' and `)' are meta characters that
must be quoted if used outside their dedicated places in the syntax.


Andreas Schwab                                  "And now for something
SuSE Labs                                        completely different."
SuSE GmbH, Schanzäckerstr. 10, D-90443 Nürnberg

reply via email to

[Prev in Thread] Current Thread [Next in Thread]