[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[subshell_pty input/output error and errors in subshell.c]

From: internut
Subject: [subshell_pty input/output error and errors in subshell.c]
Date: Fri, 26 Apr 2002 21:04:55 +0200

Configuration Information [Automatically generated, do not change]:
Machine: i386
OS: linux-gnu
Compiler: gcc
Compilation CFLAGS:  -DPROGRAM='bash' -DCONF_HOSTTYPE='i386' 
-DCONF_OSTYPE='linux-gnu' -DCONF_MACHTYPE='i386-pc-linux-gnu' 
-I/home/swt/doko/export/packages/bash/bash-2.05a/lib -g -O2
uname output: Linux perlbroker.kosmos 2.2.19-udma100-ext3 #1 SMP Sat Oct 20 
18:53:37 CEST 2001 i486 unknown
Machine Type: i386-pc-linux-gnu

Bash Version: 2.05a
Patch Level: 0
Release Status: release


I don't know what caused this error and to which package it belongs but I 
suppose it is bash.

What I have done was working in X (v4) on LyX, changed to a console and then I 
suddenly found out that X crashed because of some input/output error. But that 
was not all. Every <ENTER> on any console, simply logged me out with some 
message which was hard to see, but something like this:

subshell.c: .........I don't know (subshell_pty input/output error)
....... more text.....

Simply every login would log me out immediately. On one console I logged as 
root and root had another shell mc, so I could see that starting bash caused 
segmentation fault. Starting ash didn't cause it.

Many commands issued like bash, ls... gave segmentation fault. Command free 
worked. I could issue command reboot and have seen that many scripts from 
init.d had segmentation fault, like 7-10 scripts all together. I suppose that 
is something with bash.

Before that work I had computer up for maybe 24 hours or something. I worked a 
lot with compiling, downloading, lynx, ssh and had oppened all consoles. There 
was also network with couple LAN computers, but I had no visible hardware 
failures nor I have them now.

When I rebooted the system I could issue this bug report and I am sure that 
this happens very rare (this was the first time).

Please send me any information if subshell.c error really belongs to bash. 
Maybe it belongs to ash as it was linked as /bin/sh.

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux perlbroker.kosmos 2.2.19-udma100-ext3 #1 SMP Sat Oct 20 18:53:37 
CEST 2001 i486
Locale: LANG=hr_HR, LC_CTYPE=hr_HR

        That I cannot describe.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]