bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error installing bash-2.05a on HP-UX


From: Chet Ramey
Subject: Re: error installing bash-2.05a on HP-UX
Date: Tue, 25 Jun 2002 13:34:03 -0400

> I'm trying to do a non-root install of bash.
> 
> I've attached the output from my configure.
> 
> The error I'm getting is:
> 
>         ./mkbuiltins -D . printf.def
> 
>         cc -c  -DHAVE_CONFIG_H -DSHELL    -I. -I..  -I.. -I../include
> -I../lib -
> I. -DHPUX  -g printf.c || ( rm -f printf.c ; exit 1 )
> 
> cc: "printf.def", line 1013: error 1718: Types are not
> assignment-compatible.  =20
> *** Error exit code 1

HP/UX lies about its long double support.  Comment out the line in the
generated config.h that reads HAVE_LONG_DOUBLE and rebuild.

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
( ``Discere est Dolere'' -- chet)

Chet Ramey, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]