[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bash 2.05b

From: Gustavo Carneiro
Subject: bash 2.05b
Date: Thu, 14 Nov 2002 14:30:03 -0000

I've recentely installed  Red Hat 8.0 that comes with bash version 2.05b. I don't know much about Linux or programing but a strange thing happened that I really don't know if it is a bug on bash. I compiled a simple c++ program with gcc 3.2 that when executed shows numbers from 1 to 15 on the prompt. I did all this logged as a normal user and used the bash shell.
When I execute the program logged as a normal user the prompt shows: 
When I execute it logged as root it shows:
I don't know what causes this...I checked my .bashrc and bash_profile and it was the same as root's ones. When logged as a normal user it seems like bash is eating up the initial parts of my couts. I checked the file permissions and they were ok, and I use the same terminal window to switch from a normal user into root. So I tried to run the program with tcshr shell logged as a normal user and it worked fine. I've used RH since version 7.0, always used bash and this never happend in previous versions.
So is this a bug on bash or am I doing something wrong?
Sorry for my english.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]