bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Builtin 'read -u fd' does not work with fd other than zero.


From: Chet Ramey
Subject: Re: Builtin 'read -u fd' does not work with fd other than zero.
Date: Fri, 25 Mar 2005 11:22:18 -0500
User-agent: Mozilla Thunderbird 1.0.2 (Macintosh/20050317)

address@hidden wrote:
> Configuration Information [Automatically generated, do not change]:
> Machine: sparc
> OS: solaris2.8
> Compiler: gcc
> Compilation CFLAGS:  -DPROGRAM='bash' -DCONF_HOSTTYPE='sparc' 
> -DCONF_OSTYPE='solaris2.8' -DCONF_MACHTYPE='sparc-sun-solaris2.8' 
> -DCONF_VENDOR='sun' -DSHELL -DHAVE_CONFIG_H  -I.  
> -I/wamas/tools/haubi/src/toolsbox-4-patches/buildroot/bash/bash-2.05b 
> -I/wamas/tools/haubi/src/toolsbox-4-patches/buildroot/bash/bash-2.05b/include 
> -I/wamas/tools/haubi/src/toolsbox-4-patches/buildroot/bash/bash-2.05b/lib  -g 
> -O2
> uname output: SunOS sauxch4 5.8 Generic_108528-11 sun4u sparc 
> SUNW,Sun-Fire-280R
> Machine Type: sparc-sun-solaris2.8
> 
> Bash Version: 2.05b
> Patch Level: 0
> Release Status: release
> 
> Description:
>       When using 'read -u 3' or the like, and the pipe-buf already contains
>       more than one line, the first line is returned, and bytes up to the next
>       multiple of 128 are skipped.
> 
>       This bug quite sure exists in bash-3.0 too.

Yes, it did.  I fixed it a few weeks ago.  Thanks for the report.

Chet
-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
( ``Discere est Dolere'' -- chet )
                                                Live...Laugh...Love
Chet Ramey, ITS, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]