bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash ignoring .inputrc (or am I dumb)


From: Chet Ramey
Subject: Re: bash ignoring .inputrc (or am I dumb)
Date: Thu, 30 Mar 2006 11:17:32 -0500

> I have ^W bound to "backward-kill-word" in my .inputrc. On FreeBSD, Red
> Hat Linux, FC4, and anything else with a bash version > 3, I can't seem
> to get this to work as I expect. I've tried adding other changes to
> .inputrc, and they don't seem to be read either. I tried setting
> $INPUTRC to $HOME/.inputrc (even though that's the default), and that
> doesn't seem to work either.

Bash picks up bindings from the stty special characters.  On bash-3.1, that
behavior is optional:  look at the `bind-tty-special-chars' readline variable.

Chet

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
( ``Discere est Dolere'' -- chet )
                                                Live Strong.
Chet Ramey, ITS, CWRU    address@hidden    http://tiswww.tis.case.edu/~chet/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]