bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Constructs a-la $(echo ...) failing with "bash: cho: command not fou


From: Chet Ramey
Subject: Re: Constructs a-la $(echo ...) failing with "bash: cho: command not found"
Date: Fri, 28 Apr 2006 13:57:33 -0400
User-agent: Thunderbird 1.5.0.2 (Macintosh/20060308)

Davor Ocelic wrote:
> Configuration Information [Automatically generated, do not change]:
> Machine: mips
> OS: irix
> Compiler: c99
> Compilation CFLAGS:  -DPROGRAM='bash' -DCONF_HOSTTYPE='mips' 
> -DCONF_OSTYPE='irix' -DCONF_MACHTYPE='mips-unknown-irix' 
> -DCONF_VENDOR='unknown' -DLOCALEDIR='/usr/share/locale' -DPACKAGE='bash' 
> -DSHELL -DHAVE_CONFIG_H   -I.  -I../bash -I../bash/include -I../bash/lib  
> -I/usr/nekoware/include -g3 -O2
> uname output: IRIX64 boyd 6.5 01090133 IP30
> Machine Type: mips-unknown-irix
> 
> Bash Version: 3.1
> Patch Level: 14
> Release Status: release
> 
> Description:
>       There is a problem with bash 3 builds on IRIX 6.5/MIPS/MIPSPro 
> platform. 
>       The build goes fine, but every invocation of $(command ...) construct
>       fails. The problem surfaces in both bash test suite and later if one
>       tries to use the shell for work.

Something similar was reported once before, but appears to be irix-
specific.  I do not have access to any Irix machines, and will need
someone else to debug this.

If you're willing to take a shot at it, you can try debugging with gdb
and putting a breakpoint in subst.c:extract_command_subst().  If you
elect to do so, please let me know what you find.

Chet

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                       Live Strong.  No day but today.
Chet Ramey, ITS, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]