[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash strangeness with utf-8

From: Joe Peterson
Subject: Re: bash strangeness with utf-8
Date: Mon, 09 Jul 2007 17:24:03 -0600
User-agent: Thunderbird (X11/20070616)

Benno Schulenberg wrote:
> On what terminal are you doing this?  To what encoding is the 
> terminal set?

Mainly xterm (version 225, at least in one case).  And I have the utf8
option on.  Does this set the encoding to the proper value, or do I need

But also, I have tried this in the simple virtual terminal (ctrl-alt-f1,
etc.), which also exhibits the problem.  Not sure what encoding is used

> Then re-emerge baselayout.  That should give you a default inputrc. 
> In that file maybe these flags are relevant to your problem:

I suspect the Gentoo/FreeBSD baselayout doesn't have this (since it is
missing on both of my systems).  Perhaps it's Linux-only?  If it should
exist on BSD, I'll talk to the baselayout guy.

> set meta-flag on
> set input-meta on
> set convert-meta off
> set output-meta on

I made a .inputrc with the above contents and then ran bash.  Same results.

> If still no luck, then maybe your readline is broken?  But first 
> check that everyting is emerged with the unicode USE flag.

Maybe, I thought of that at one point.  I'm using readline 5.2_p4.
Also, I've always had the unicode USE flag in my make.conf, so at least
that's always been enabled.

> Or wait, which ncurses are you using?  If 5.6*, then mask it and go 
> back to 5.5-r3 and see if that helps.

I was indeed using version 5.6.  I downgraded to 5.5-r3, but same results.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]