bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Nasty PS1 bug


From: Alexander Renn
Subject: Nasty PS1 bug
Date: Wed, 6 Feb 2008 23:05:13 +0200

Hello,

I noticed a bug that appeared in bash recently.

Everything worked OK on this version:
GNU bash, version 2.05b.0(1)-release (i386-portbld-freebsd4.10)
Copyright (C) 2002 Free Software Foundation, Inc.

Now I'm having troubles on this version:
GNU bash, version 3.1.17(0)-release (i386-portbld-freebsd6.2)
Copyright (C) 2005 Free Software Foundation, Inc.

How to reproduce (used PUTTY and konsole to test):
Save the uuencoded bash_profile file and load it into bash:

# . bash_profile

You'll get the command prompt like this:

0 address@hidden:ttyp3 ~ 23:05:52 1>

Now type anything of such length that the cursor will be below the command
prompt:

1 address@hidden:ttyp3 ~ 23:09:19 1> this is a test string that will be wrapped
 down

Now hit HOME END HOME END keys.

The command prompt will be messed up in the newer bash versions.

It worked OK in older versions, e.g. bash 2.05b.0(1)



--
Best regards,
Alexander Renn

Phone: +380632311922
E-mail/Jabber: address@hidden
ICQ: 50088883

Attachment: bash_profile
Description: Binary data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]