bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

--rcfile still opening the SYS_BASHRC


From: Lluís Batlle
Subject: --rcfile still opening the SYS_BASHRC
Date: Thu, 14 May 2009 21:28:17 +0200

Hello,

I have a problem in bash (3.2 and 4). I have it compiled with
"-DSYS_BASHRC=/etc/bashrc", and since some time ago I could use "bash
--rcfile ~/.myrc" to skip the parsing of /etc/bashrc.

I can't recall what was the compile configuration of that bash where
this worked. But in the latest bash 3.2 and 4 I've tried (for 4, I
have all patches published), using "--rcfile" *parses* /etc/bashrc

According to the manual, "--rcfile" should make bash avoid the system bashrc.

If I try "bash --norc" (which is not convenient for my needs), it
avoids the system and the personal bashrc. According to the manual,
this should skip only the personal bashrc.

Moreover, about parameter parsing, in bash versions 3.2 and 4, trying
to run "bash -i --rcfile xxx" results in bad parameter parsing,
getting a complain about parameter "--".

What do you think? Have I hit some bugs?

Please keep me in copy, as I'm not subscribed to address@hidden

Regards,
Lluís




reply via email to

[Prev in Thread] Current Thread [Next in Thread]