[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash does not wait for called script to finish

From: Seved Torstendahl
Subject: Re: bash does not wait for called script to finish
Date: Thu, 28 May 2009 12:57:18 +0200
User-agent: Thunderbird (Windows/20090302)

Chet Ramey skrev:
Seved Torstendahl wrote:
Configuration Information [Automatically generated, do not change]:
Machine: x86_64
OS: linux-gnu
Compiler: gcc
Compilation CFLAGS:  -DPROGRAM='bash' -DCONF_HOSTTYPE='x86_64' 
-DCONF_OSTYPE='linux-gnu' -DCONF_MACHTYPE='x86_64-pc-linux-gnu' 
-DCONF_VENDOR='pc' -DLOCALEDIR='/usr/share/locale' -DPACKAGE='bash' -DSHELL 
-DHAVE_CONFIG_H   -I.  -I../bash -I../bash/include -I../bash/lib   -g -O2
uname output: Linux jessie 2.6.18-5-amd64 #1 SMP Sat Dec 22 20:43:59 UTC 2007 
x86_64 GNU/Linux
Machine Type: x86_64-pc-linux-gnu

Bash Version: 3.1
Patch Level: 17
Release Status: release

The first thing you need to do is to see whether or not it occurs with
the latest bash version and patchlevel: 3.2 patch 39.


This problem has not occurred any more. We have made two changes:

1. Upgraded bash to version 3.2.39 by fetching the source code, applying
   the patches and compiling for the used machine (amd64, 4 processors)
   The change log indicates that there has been problems with parallel

2. Upgraded the kernel due to a bug with inodes on huge RAM disks.

Personally I think that bash-3.2.39 solved the problem.

This is just to inform you that I consider this issue solved.

Seved Torstendahl

reply via email to

[Prev in Thread] Current Thread [Next in Thread]