bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bash segmentation fault on startup/ssh


From: Nitz
Subject: Bash segmentation fault on startup/ssh
Date: Fri, 30 Mar 2012 15:42:08 -0400

Configuration Information [Automatically generated, do not change]:
Machine: i386
OS: linux-gnu
Compiler: gcc
Compilation CFLAGS:  -DPROGRAM='bash' -DCONF_HOSTTYPE='i386'
-DCONF_OSTYPE='linux-gnu' -DCONF_MACHTYPE='i386-redhat-linux-gnu'
-DCONF_VENDOR='redhat' -DLOCALEDIR='/usr/share/locale'
-DPACKAGE='bash' -DSHELL -DHAVE_CONFIG_H   -I.  -I. -I./include
-I./lib  -D_GNU_SOURCE -DRECYCLES_PIDS -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32
-march=i686 -mtune=atom -fasynchronous-unwind-tables -fwrapv
uname output: Linux xxxxxx.xxxx.xxx 2.6.32-131.21.1.el6.i686 #1 SMP
Fri Nov 11 11:51:22 EST 2011 i686 i686 i386 GNU/Linux
Machine Type: i386-redhat-linux-gnu

Bash Version: 4.1
Patch Level: 2
Release Status: release

Description:

I am getting a segmentation fault from bash when I try to SSH to a
remote server (running RHEL 4.4.5-6). After providing my credentials,
the SSH client spits back the "Last login: ..." information, and then
just hangs.

Out of curiosity, I pressed Ctrl-C and was able to get to a bash
prompt. However, it's not the "usual" prompt that I see (it usually
has my username, the server hostname, etc).

login as: xxxxxxx
address@hidden's password:
Last login: Fri Mar 30 14:33:41 2012 from xxx.xx.xx.xxx

-bash-4.1$ echo $0
-bash
-bash-4.1$

I tried to run /bin/bash from GDB. After a little hang time, I finally
got a SIGSEGV error:

(gdb) run
Starting program: /bin/bash

Program received signal SIGSEGV, Segmentation fault.
0x08067ab5 in yyparse ()
(gdb)

The last (significant) changes that I've made to the system was
installing GNU screen (using yum install screen). Screen seemed to
hang as well when I tried to start it (I'm assuming because it tried
running bash, and got the same segfault).


I tried running rpm -V to verify the bash package:

-bash-4.1$ rpm -V bash
-bash-4.1$

All of my .bash* files seem to check out (.bashrc, .bash_profile,
.bash_logout) and have nothing abnormal in them from what I can tell.
I can provide those if necessary.

Repeat-By:

Logging into the server via SSH. Trying to run /bin/bash.

--
Thanks,
Nick



reply via email to

[Prev in Thread] Current Thread [Next in Thread]