[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How does one disable completion when nothing but tabs or spaces is o

From: Linda Walsh
Subject: Re: How does one disable completion when nothing but tabs or spaces is on the line?
Date: Sat, 05 Jan 2013 17:36:07 -0800
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20100228 Lightning/0.9 Thunderbird/ Mnenhy/

Chet Ramey wrote:

OK, if readline as it currently exists doesn't offer the feature you want,
why not take a shot at writing it?  You might find that others like it as
well, though none of them have spoken up so far.
        This feature used to exist in 3.0.  You "fixed it" to only
work at the command prompt.  It would be useful, as you did the work
to create the new functionality, if that fix could be put into an option.

        This was asked for at the time, but it didn't seem you wanted
such an option at the time.  Either that, or you didn't understand the

        I could simply submit the readline functionality (assuming that's
where you made the change) from 3.0, and it would work again, but that
would remove your new changes.  I assume that wouldn't be desirable.

        What would be desirable is if you could either change your fix
to be something that can optionally be turned off, or point to the place
where you made your fix.

As for the binding:

 Create an inputrc file with:

"`": completion
"TAB": self-insert

What you've done here is bind backquote to a non-existent function and the
three-character sequence `T'`A'`B' to `B'.

A few minutes of testing with an inputrc consisting of

"`": complete
TAB: self-insert
        Thank-you for pointing my confusion.  However, what I'd rather have,
ties in with the last paragraph you neglected to mention:

   "I also noticed bash doesn't recognize META-key sequences in vi-mode.
   Yet it does recognize ESC-prefixed cursor-key sequences as not being "ESC",
   but I should likely address that in a separate email so as not to confuse
   the issue."

(likely because I indicated it might be useful separately, but it was in my head
because I'd rather have a simple):

META-TAB: complete
TAB: self-insert.

But Meta didn't seem to work in VI mode last I tried it.

Has that been fixed (readline treated the 'ESC' leading as single char,
rather than part of a key-sequence as it does in cursor-key movement).

That would likely solve my problem and cleanly allow me to paste text
into/onto the command line and not have it be corrupted.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]