[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bash install on Windows 7 using SUA

From: Eric Blake
Subject: Re: Bash install on Windows 7 using SUA
Date: Tue, 02 Jul 2013 14:44:35 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130625 Thunderbird/17.0.7

On 07/02/2013 12:20 PM, Chris Irvine wrote:
> I tried to download the BASH for my Windows 7 computer with SUA (services
> for Unix installed).  The latest download script, config.guess, was used and
> the configure command failed with an error.  I have attached a picture of
> the error message in a Word document.

Sheesh - you made people have to read a non-free file format to see a
screenshot, instead of just copying and pasting the text of the error
message itself.  Stunts like that cause undue network congestion, and
alienate you from free software developers who try to stay as far away
from proprietary software as possible.

Your screenshot shows that your build error boils down to:

loadmsgcat.c: In function `get_sysdep_segment_value':
loadmsgcat.c:727: error: `uintmax_t' undeclared (first use in this function)

which means your system has incomplete headers, and no one else has ever
tried working around that bug.

SUA is a rather wimpy porting platform.  Have you considered trying
Cygwin instead (see cygwin.com), so that you don't have to put up with
all the non-conforming incomplete POSIX garbage that Microsoft is
pushing with their SUA platform?

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]