bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest fix for DEBUG causes pipes to fail when used with trap and an


From: Chet Ramey
Subject: Re: Latest fix for DEBUG causes pipes to fail when used with trap and an interactive shell
Date: Fri, 28 Feb 2014 07:56:20 -0500
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Thunderbird/24.1.1

On 2/28/14 2:48 AM, Moe Tunes wrote:

> Machine Type: i686-pc-linux-gnu
> 
> Bash Version: 4.3
> Patch Level: 0
> Release Status: release
> 
> Description:
>     Pipes stop working in this version when DEBUG is used with trap in an
> interactive shell
> 
> Repeat-By:
>      pgas | # bash -c 'trap : DEBUG;echo foo | grep -v foo';echo OK
>      shbot | pgas: OK
>      pgas | # bash -ci 'trap : DEBUG;echo foo | grep -v foo';echo OK
>      shbot | pgas: no output within the time limit
>      pgas | this is not ok
>      pgas | # bash -c 'echo $BASH_VERSION'
>      shbot | pgas: 4.3.0(3)-release

Thanks for the report.  This appears to be a Linux-specific problem related
to job control.  It doesn't happen on Mac OS X, Solaris, or FreeBSD, and
using -m instead of -i causes it as well.  I'll take a look.

Chet

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, ITS, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]