bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bash-4.4-beta available for FTP


From: Michael Felt
Subject: Re: Bash-4.4-beta available for FTP
Date: Thu, 25 Feb 2016 13:34:58 +0000

AIX is "no more entitled" to it, but they are using it - and "it" is stopping make from succeeding.

+  > .buildaix/make.out
../src/bash-4.4/parse.y: warning: 1 shift/reduce conflict [-Wconflicts-sr]
"../src/bash-4.4/execute_cmd.c", line 4655.16: 1506-068 (W) Operation between types "struct array*" and "volatile struct array*" is not allowed.
"../src/bash-4.4/execute_cmd.c", line 4657.16: 1506-068 (W) Operation between types "struct array*" and "volatile struct array*" is not allowed.
"/usr/include/mbstr.h", line 47.22: 1506-334 (S) Identifier mbchar_t has already been defined on line 175 of "../src/bash-4.4/include/shmbchar.h".
make: 1254-004 The error code from the last command is 1.

This is from a build done from the beta release from 24 hours ago.

Michael

On Mon, Oct 26, 2015 at 4:40 PM, Chet Ramey <address@hidden> wrote:
On 10/23/15 1:50 PM, Michael Felt wrote:
> I do not mind installing yacc :)

You would need to install bison anyway.

> How about the redefine of mbchar_t ?

See my previous reply; AIX is no more entitled to this symbol than anyone
else.  Bash doesn't actually use this symbol internally, since it only uses
some of the functions from the gnulib implementation, so I imagine I could
just excise it from the header file if I had to.

Chet
--
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, ITS, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/


reply via email to

[Prev in Thread] Current Thread [Next in Thread]