[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash 4.4-rc1 EXECIGNORE not fully working?

From: Eric Blake
Subject: Re: bash 4.4-rc1 EXECIGNORE not fully working?
Date: Fri, 18 Mar 2016 10:27:54 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.6.0

On 03/18/2016 10:09 AM, Dennis Williamson wrote:
> $ type -a ls
> ls is /bin/ls
> $ # ls tab completion includes ls
> $ ls foo
> foo
> $ EXECIGNORE=/bin/ls
> $ type -a ls
> bash: type: ls: not found
> $ # ls tab completion does not include ls
> $ ls foo
> foo
> $ /bin/ls foo
> foo
> So ls is still executed despite the setting. I tried the same with
> /usr/bin/find and got the same result.

What were you expecting to have happen?  EXECIGNORE only controls
whether a file matching the glob is excluded from tab completions (which
it sounds like it did), not whether bash will avoid executing it (and
you proved that it is still executable).

The main use for EXECIGNORE is for ignoring *.so or *.dll files, which
must have executable permissions, but which you do not want polluting
tab completion.

So, without further details, I don't see any bug here.

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]