bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Test exit status misinterpreted in scripts when buit without job con


From: Dan Cross
Subject: Re: Test exit status misinterpreted in scripts when buit without job control
Date: Fri, 5 Aug 2016 15:59:37 -0400

On Fri, Aug 5, 2016 at 3:22 PM, Chet Ramey <address@hidden> wrote:
On 8/4/16 5:04 PM, Dan Cross wrote:

>     Thanks for the report.  I took a quick look at this, and it's not disabling
>     job control that does it: it's disabling both job control and nls.
>     Disabling either one while leaving the other enabled doesn't produce this
>     error (which only happens in the case where you run a script with the
>     execute bit set without a #! line after running an executable that causes
>     the shell to call waitpid()).  It's a strange set of circumstances.
>     I'll see what I can find.
>
>
> Thanks, Chet. FYI, I tried building for the research kernel with NLS
> enabled and am still seeing the problem.

It turns out that the set of circumstances I listed above is essential,
and order-specific.  I tested in a slightly different order when I built
a version without nls and job control, and that was the sequence that
triggers the bug.  It's very specific.

Anyway, I fixed it and the fix will be in the next release.  If you
want to move forward, you can apply the attached workaround, which is not
the change I made in the current development version.

This is wonderful; thank you very much!

        - Dan C.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]